Creating VLAN's
Voice VLAN
Switch#conf t
Switch(config)#vlan <VLAN ID>
Switch(config-vlan)#name Voice - description of the VLAN
Similarly for the Data VLAN
Creating VLAN interfaces (SVI's) and assigning IP address to them:
Switch#conf t
Switch(config)#interface vlan <VLAN ID>
Switch(config-if)#ip address <X.X.X.X> <X.X.X.X> - IP address Subnet Mask
(The ip address should be one of the useable IP addresses of the phone or data subnet)
Similarly for the Data VLAN
Interface configuration - Data/Voice
Switch#conf t
Switch(config)#interface GigabitEthernet <interface ID>
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan <VLAN ID> - data VLAN in case of PC
or
Switch(config-if)#switchport voice vlan <VLAN ID> - Voice VLAN in case of phone
If QOS is to be applied
Switch(config)#mls qos - Enabline QOS globally on the switch
Switch(config)#interface GigabitEthernet <interface ID>
Switch(config-if)#auto qos voip trust
Case 2: PC's connected via switchport behind the IP phone.
Creating VLAN's
Voice VLAN
Switch#conf t
Switch(config)#vlan <VLAN ID>
Switch(config-vlan)#name Voice - description of the VLAN
Similarly for the Data VLAN
Creating VLAN interfaces (SVI's) and assigning IP address to them:
Switch#conf t
Switch(config)#interface vlan <VLAN ID>
Switch(config-if)#ip address <X.X.X.X> <X.X.X.X> - IP address Subnet Mask
(The ip address should be one of the useable IP addresses of the phone or data subnet)
Similarly for the Data VLAN
Interface configuration - Data/Voice
Switch#conf t
Switch(config)#interface GigabitEthernet <interface ID>
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk native vlan <VLAN ID> - Data VLAN
Switch(config-if)#switchport access vlan <VLAN ID> - Voice VLAN
OR
Switch#conf t
Switch(config)#interface GigabitEthernet <interface ID>
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#switchport mode access
Switch(config-if)#switchport voice vlan <Voice VLAN ID>
Switch(config-if)#switchport access vlan <VLAN ID>
* With newer IOS it is not required that a switchport connecting a phone piggybacking a PC to be configured as a trunk specifically. Please see the secondary configuration above.
If QOS is to be applied
Switch(config)#mls qos - Enabline QOS globally on the switch
Switch(config)#interface GigabitEthernet <interface ID>
Switch(config-if)#auto qos voip trust
Or
Switch(config-if)#auto qos voip trust cisco-phone (specifically for Cisco IP phones)
Note: The above mentioned commands are version specific, however are same or similar in most of the cases.
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 6
Switch(config-if)# switchport voice vlan 38
Switch(config-if)# end
Switch(config)#mls qos - Enabline QOS globally on the switch
Switch(config)#mls qos
Switch(config)#interface GigabitEthernet 0/1
Switch(config-if)#auto qos voip trust
ip dhcp pool ali
network 192.168.1.0 255.255.255.0
option 150 ip 192.168.1.1
!
ip dhcp pool veli
network 192.168.2.0 255.255.255.0
-------------------
Router#sh ephone
ephone-1 Mac:0001.C706.315D TCP socket:[1] activeLine:1 UNREGISTERED
mediaActive:0 offhook:1 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:0.0.0.0 0 keepalive 43 max_line 2
button 1: dn CH1 DOWN
ephone-2 Mac:0004.9A15.D142 TCP socket:[1] activeLine:1 UNREGISTERED
mediaActive:0 offhook:1 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:0.0.0.0 0 keepalive 43 max_line 2
button 1: dn CH1 DOWN
ephone-3 Mac:0006.2A76.0AD2 TCP socket:[1] activeLine:1 UNREGISTERED
mediaActive:0 offhook:1 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:0.0.0.0 0 keepalive 43 max_line 2
button 1: dn CH1 DOWN
Router#
config dosyası:
Router#sh run
Building configuration...
Current configuration : 1363 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
ip dhcp pool DataDHCPDagitimi
network 192.168.100.0 255.255.255.240
default-router 192.168.100.1
option 150 ip 192.168.100.1
ip dhcp pool VoiceDHCPDagitimi
network 192.168.100.16 255.255.255.240
default-router 192.168.100.17
option 150 ip 192.168.100.17
!
!
!
ip cef
no ipv6 cef
!
!
!
!
spanning-tree mode pvst
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 192.168.100.1 255.255.255.240
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
ip address 192.168.100.17 255.255.255.240
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
telephony-service
max-ephones 3
max-dn 3
ip source-address 192.168.100.1 port 2000
!
ephone-dn 1
number 1453
!
ephone-dn 2
number 1999
!
ephone-dn 3
number 2017
!
ephone 1
device-security-mode none
mac-address 0007.EC45.9E9A
type 7960
button 1:1
!
ephone 2
device-security-mode none
mac-address 0009.7C61.65EB
type 7960
button 1:2
!
ephone 3
device-security-mode none
mac-address 000D.BD67.B2C3
type 7960
button 1:3
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
switch kodları :
Switch(config-if-range)#do sh run
Building configuration...
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
switchport voice vlan 20
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
switchport voice vlan 20
spanning-tree portfast
ephone-1 Mac:0001.C706.315D TCP socket:[1] activeLine:1 UNREGISTERED
mediaActive:0 offhook:1 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:0.0.0.0 0 keepalive 43 max_line 2
button 1: dn CH1 DOWN
ephone-2 Mac:0004.9A15.D142 TCP socket:[1] activeLine:1 UNREGISTERED
mediaActive:0 offhook:1 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:0.0.0.0 0 keepalive 43 max_line 2
button 1: dn CH1 DOWN
ephone-3 Mac:0006.2A76.0AD2 TCP socket:[1] activeLine:1 UNREGISTERED
mediaActive:0 offhook:1 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:0.0.0.0 0 keepalive 43 max_line 2
button 1: dn CH1 DOWN
Router#
config dosyası:
Router#sh run
Building configuration...
Current configuration : 1363 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
ip dhcp pool DataDHCPDagitimi
network 192.168.100.0 255.255.255.240
default-router 192.168.100.1
option 150 ip 192.168.100.1
ip dhcp pool VoiceDHCPDagitimi
network 192.168.100.16 255.255.255.240
default-router 192.168.100.17
option 150 ip 192.168.100.17
!
!
!
ip cef
no ipv6 cef
!
!
!
!
spanning-tree mode pvst
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.10
encapsulation dot1Q 10
ip address 192.168.100.1 255.255.255.240
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
ip address 192.168.100.17 255.255.255.240
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
telephony-service
max-ephones 3
max-dn 3
ip source-address 192.168.100.1 port 2000
!
ephone-dn 1
number 1453
!
ephone-dn 2
number 1999
!
ephone-dn 3
number 2017
!
ephone 1
device-security-mode none
mac-address 0007.EC45.9E9A
type 7960
button 1:1
!
ephone 2
device-security-mode none
mac-address 0009.7C61.65EB
type 7960
button 1:2
!
ephone 3
device-security-mode none
mac-address 000D.BD67.B2C3
type 7960
button 1:3
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
switch kodları :
Switch(config-if-range)#do sh run
Building configuration...
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
switchport voice vlan 20
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
switchport voice vlan 20
spanning-tree portfast
---------------------------
HP ‘de önemli olan voice vlan’avoice yazmak. Cdp komuta varsa enable yapılabilir.
Backbone’da voice ile ilgili dhcp ve vlan ayarı.
2610 Switch’de
voice ile ilgili dhcp ve vlan ayarı.
HPE
1920-24G-PoE+ (370W) (JG926A) Switch’de voice ile ilgili dhcp ve vlan ayarı.
-----------------
lldp global enable
undo voice-vlan security enable
voice-vlan track lldp
port config
-----------------
#voice vlan 220 ise
#data vlan 20 ise
örnek port configi
interface GigabitEthernet1/0/20
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 20 220
port trunk pvid vlan 20
undo voice-vlan mode auto
voice-vlan 220 enable
stp edged-port
lldp compliance admin-status cdp txrx
poe enable
interface GigabitEthernet1/0/1
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 95 tagged
port hybrid vlan 105 untagged
port hybrid pvid vlan 105
undo voice-vlan mode auto
voice-vlan 95 enable
stp edged-port
lldp compliance admin-status cdp txrx
poe enable
dhcp server ip-pool branchvlan extended
network ip range 10.1.1.31 10.1.1.130
network mask 255.255.255.0
gateway-list 10.1.1.254
dns-list 10.2.2.10 10.2.2.11
domain-name domain.local
expired day 8
option 150 ip-address 10.3.3.20 10.3.3.21
interface Vlan-interface20
ip address 10.1.1.1 255.255.255.0
dhcp server apply ip-pool branchvlan
HUAWEI
uawei switch üzerinde cdp protokolünü aktif etmeniz gerekmetedir. huawei switch zerine ip telefon bağlanma durumuna karşı temel konfigürasyonu adım adım yapalım.
öncelikle ses (voice) için kullanacağımız vlanı oluşturalım.
Hiç yorum yok:
Yorum Gönder