- Tc (time interval) is the time in milliseconds over which we can send the Bc (committed burst).
- Bc (committed burst) is the amount of traffic that we can send during the Tc (time interval) and is measured in bits.
- CIR (committed information rate) is the bitrate that is defined in the “traffic contract” that we received from the ISP.
There are a number of formulas that we can use to calculate the values above:
Bc value:
Bc = Tc * CIR
In the example above we have a Tc of 125 ms
burst 'ın anlamıTime Interval (Tc) * CIR = Bc
Cır : bant genıslıgımız ornegin 8 gigabitlik hattımız var bunu default deger 0.125sn
ile carparsak burst değerimiz yani saniyede yollayabileceğimiz maksimum deger ortaya
çıkar. Sonuc olarak 8 gigabit * 0.125sn =1 gigabit dir.
Tc:TC değeri default olarak 125 ms default olarak cisco da 8 sanyine bir paket yollanır.
BC: Her bir zaman zaman aralığında (TC zaman aralığı ) gönderilen bit cinsinden data miktarını
BC (Committed Burst) olarak ifade ediyoruz.
Peki Be nedir ? Biliyoruz ki 62 ms paket gonder 62 ms bekle ile çalısıyor be kısmı bekleme süresidir. cisco eğer bir sıkısma olursa be devreye giriyor ve altaki grafik olması gerekirken be ile ikinci grafik ortaya cıkıyor.
The most recent Cisco IOS versions always prefer a Tc of 4 ms and will calculate the Bc value accordingly. On older Cisco IOS versions it’s possible that you see higher Bc values with a Tc of 125 ms.
The first 3 bits are used to define the class and the next 3 bits are used to define the drop probability. Here are all the possible values that we can use:
Drop | Class 1 | Class 2 | Class 3 | Class 4 |
Low | 001010
AF11
| 010010
AF21
| 011010
AF31
| 100010
AF41
|
Medium | 001100
AF12
| 010100
AF22
| 011100
AF32
| 100100
AF42
|
High | 001110
AF13
| 010110
AF23
| 011110
AF33
| 100110
AF43
|
Class 4 has the highest priority. For example, any packet from class 4 will always get better treatment than a packet from class 3.
R1(config)#class-map TELNET
R1(config-cmap)#match protocol telnet
R1(config)#class-map HTTP
R1(config-cmap)#match protocol http
R1(config)#policy-map CBWFQ
R1(config-pmap)#class TELNET
R1(config-pmap-c)#bandwidth percent 10
R1(config-pmap-c)#exit
R1(config-pmap)#class HTTP
R1(config-pmap-c)#bandwidth percent 20
R1(config-pmap-c)#exit
Nothing special here…just a simple CBWFQ configuration that gives 10% of the bandwidth to telnet and 20% to HTTP traffic. Let’s try to apply it to the sub-interface:
R1(config)#interface serial 0/0.1
R1(config-subif)#service-policy output CBWFQ
R2(config)#class-map ICMP
R2(config-cmap)#match protocol icmp
R2(config)#policy-map SINGLE-RATE-TWO-COLOR
R2(config-pmap)#class ICMP
R2(config-pmap-c)#police 128000 conform-action transmit exceed-action drop
R2(config)#interface FastEthernet 0/0
R2(config-if)#service-policy input SINGLE-RATE-TWO-COLOR
R2#show policy-map interface FastEthernet 0/0
qos te dikkat edilmesi gereken nokta iki tarafta da paketlerin isaretlenmesi gerekmektedir. Cihazlar üzerinde benzer konfigurasyonlar yapılır . Uctan uca qos icin isteğe göre değişekenlik gösterir. Ayrıca tunnel interface'inde dikkat edilmesi gereken husus pacet encrypt oldugu için qos pre-classify komutu kullanılmalıdır.ilk olarak oncelik verilecek paketler belirleniyor
Code:
# access-list 100 permit udp any any
ardindan bu paketleri etiketleme islemi icin bir class altina koyuyoruz
#class-map match-all udp
#match access-group 100
ardindan bu classin oncelik degerini belitiyoruz
#policy-map udp
#class udp
#set ip precedence 5
ardinadan hangi interfaceden gelen paketleri etiketleyecegini belirtiyoruz
#interface FastEthernet0/0
# service-policy input udp
Code:
paketleri routera gelis yonunde etiketledik
simdi routerdan cikarken oncelik vermemiz gerekir
#class-map match-all udp-out
#match ip precedence 5
Code:
#policy-map udp-out
#class udp-out
#priority percent 10
bu policy i cikis interfacene yaziyoruz
#interface Serial1/0
# service-policy output udp-out
tabi bu yarim bir Quality of Service(QoS) dir
Sadece User Datagram Protocol(UDP) Paketlerine bir oncelik veriyor.
*----------------
class map , policy map , service policy sırasıyla giderilir.
class mapteki all and yapar any or yapar.
Önceliklendirme dışında kalanlar için class-default oluşturulur. (Oluşturulmaz ise problem olmaz)
class-map HTTP
match protocol http
!
policy-map PM
class HTTP
bandwidth 2000
class class-default
bandwidth 6000
!
interface Serial0/0
service-policy output PM
DiffServ Model;
Öncelikli trafik gelince öncelik verilir.
İnserv Model;
Bir trafik ayrılır ve hiç kullanılmaz. Etiketlene trafik geldiğinde direk olarak geçer. DiffServ'de bir bekleme süresi oluşabilir.
Ip Precedence and Dscp Compatibility
Dscp 64 bit
Precedence 8 bit kullanır(0-5 arası 6 ve 7 routing protocolleri için ayrılmıstır.) = cs dir.
ef (en öncelikli)
af (az öncelikli)
af11 önce drop
af12 medium
af13 en son drop edilir.
Router 'da Qos için hattın yuzde 75'ini kullanır. Hesap yaparken 1 gb değil 750mgbit alır.
Örnek Layer2 Konfigürasyonları ;
----
class-map match-all voice
match access-group 105
!
policy-map voip
class voice
priority 96
class class-default
fair-queue
access-list 105 permit ip any host 10.101.0.10
access-list 105 permit ip any any dscp ef
access-list 105 permit ip any any dscp cs5
ADANA(config-if)#service-policy output voip
------
table-map AutoQos-4.0-Trust-Dscp-Table
default copy
table-map AutoQos-4.0-Trust-Cos-Table
default copy
!
class-map match-any AutoQos-4.0-Output-Bulk-Data-Queue
match dscp af11 af12 af13
match cos 1
class-map match-any AutoQos-4.0-Output-Trans-Data-Queue
match dscp af21 af22 af23
match cos 2
class-map match-any AutoQos-4.0-Output-Control-Mgmt-Queue
match dscp cs2 cs3 cs6 cs7
match cos 3
class-map match-any AutoQos-4.0-Output-Multimedia-Conf-Queue
match dscp af41 af42 af43
match cos 4
class-map match-any AutoQos-4.0-Output-Priority-Queue
match dscp cs4 cs5 ef
match cos 5
class-map match-any AutoQos-4.0-Output-Multimedia-Strm-Queue
match dscp af31 af32 af33
class-map match-any non-client-nrt-class
class-map match-any AutoQos-4.0-Output-Scavenger-Queue
match dscp cs1
policy-map AutoQos-4.0-Output-Policy
class AutoQos-4.0-Output-Priority-Queue
priority level 1 percent 30
class AutoQos-4.0-Output-Control-Mgmt-Queue
bandwidth remaining percent 10
queue-limit dscp cs2 percent 80
queue-limit dscp cs3 percent 90
queue-limit dscp cs6 percent 100
queue-limit dscp cs7 percent 100
queue-buffers ratio 10
class AutoQos-4.0-Output-Multimedia-Conf-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
class AutoQos-4.0-Output-Trans-Data-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
class AutoQos-4.0-Output-Bulk-Data-Queue
bandwidth remaining percent 4
queue-buffers ratio 10
class AutoQos-4.0-Output-Scavenger-Queue
bandwidth remaining percent 1
queue-buffers ratio 10
class AutoQos-4.0-Output-Multimedia-Strm-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
class class-default
bandwidth remaining percent 25
queue-buffers ratio 25
policy-map AutoQos-4.0-Trust-Cos-Input-Policy
class class-default
set cos cos table AutoQos-4.0-Trust-Cos-Table
policy-map AutoQos-4.0-Trust-Dscp-Input-Policy
class class-default
set dscp dscp table AutoQos-4.0-Trust-Dscp-Table
!
interface GigabitEthernet1/0/14
switchport access vlan 9
power inline never
auto qos trust cos
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
interface GigabitEthernet1/0/47
switchport access vlan 20
duplex full
auto qos trust dscp
spanning-tree portfast
spanning-tree bpduguard enable
service-policy input AutoQos-4.0-Trust-Dscp-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
interface TenGigabitEthernet1/1/4
description ***Backbone***
switchport mode trunk
channel-group 1 mode active
service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
-----
table-map AutoQos-4.0-Trust-Cos-Table
default copy
class-map match-any AutoQos-4.0-Output-Multimedia-Conf-Queue
match dscp af41 af42 af43
match cos 4
class-map match-any AutoQos-4.0-Output-Bulk-Data-Queue
match dscp af11 af12 af13
match cos 1
class-map match-any AutoQos-4.0-Output-Priority-Queue
match dscp cs4 cs5 ef
match cos 5
class-map match-any AutoQos-4.0-Output-Multimedia-Strm-Queue
match dscp af31 af32 af33
class-map match-any non-client-nrt-class
class-map match-any AutoQos-4.0-Output-Trans-Data-Queue
match dscp af21 af22 af23
match cos 2
class-map match-any AutoQos-4.0-Output-Scavenger-Queue
match dscp cs1
class-map match-any AutoQos-4.0-Output-Control-Mgmt-Queue
match dscp cs2 cs3 cs6 cs7
match cos 3
!
policy-map port_child_policy
class non-client-nrt-class
bandwidth remaining ratio 10
policy-map AutoQos-4.0-Output-Policy
class AutoQos-4.0-Output-Priority-Queue
priority level 1 percent 30
class AutoQos-4.0-Output-Control-Mgmt-Queue
bandwidth remaining percent 10
queue-limit dscp cs2 percent 80
queue-limit dscp cs3 percent 90
queue-limit dscp cs6 percent 100
queue-limit dscp cs7 percent 100
queue-buffers ratio 10
class AutoQos-4.0-Output-Multimedia-Conf-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
class AutoQos-4.0-Output-Trans-Data-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
class AutoQos-4.0-Output-Bulk-Data-Queue
bandwidth remaining percent 4
queue-buffers ratio 10
class AutoQos-4.0-Output-Scavenger-Queue
bandwidth remaining percent 1
queue-buffers ratio 10
class AutoQos-4.0-Output-Multimedia-Strm-Queue
bandwidth remaining percent 10
queue-buffers ratio 10
class class-default
bandwidth remaining percent 25
queue-buffers ratio 25
policy-map AutoQos-4.0-Trust-Cos-Input-Policy
class class-default
set cos cos table AutoQos-4.0-Trust-Cos-Table
!
interface TenGigabitEthernet1/0/1
description *** FTD_1-13 ***
switchport mode trunk
speed nonegotiate
auto qos trust cos
channel-group 1 mode active
spanning-tree portfast trunk
service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
!
interface TenGigabitEthernet1/0/2
description *** FTD_2-13 ***
switchport mode trunk
speed nonegotiate
auto qos trust cos
channel-group 2 mode active
spanning-tree portfast trunk
service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
service-policy output AutoQos-4.0-Output-Policy
----
Cisco QOS modeline göre 7 seviye vardır. Bunlardan 6 ve 7 öncelik değerine sahip olanlar sadece networkün yönetimi ve çalışması için gereklidir. Bu otomatik olarak rezerve edilir. Diğerleri (5-…0) olanlar öncelik değeri büyük olanlar önce geçer.
Yapım aşaması:
•Belirlenen IP ve/veya portlara göre access-list hazırlanır.
•Hazırlanan Access-listlere göre sınıflandırma işlemi yapılır.
•Oluşturulan sınıfların ToS bitlerin işaretleme yapılır (marking).
•Önceliklendirme dışında kalanlar için class-default oluşturulur. (Oluşturulmaz ise problem olmaz)
•Router’in istenilen interface’ine uygulanır.
Ben kendi yaptığım bir örneği sizinle paylaşmak istiyorum.
ACCESS-LIST'LERİ OLUŞTURMA
ip Access-list extended 5_INCI_ONCELIK (Kritik makinalar için IP bazlı)
permit ip any host 10.1.1.1
permitip host 10.1.1.1 any
ip Access-list extended 4_UNCU_ONCELIK (Port bazlı)
permit tcp any any eq 21
permit udap any any 69
ip Access-list extended 3_UNCU_ONCELIK
…
ip Access-list extended 2_NCI_ONCELIK
…
ip Access-list extended 1_INCI_ONCELIK
….
!SINIFLANDIRMA
Class-map match any 5_INCI_ONCELIK
Macth Access-group name KRITIK5
Class-map match any 4_UNCU_ONCELIK
Macth Access-group name KRITIK4
Class-map match any 3_UNCU_ONCELIK
Macth Access-group name KRITIK3
Class-map match any 2_NCI_ONCELIK
Macth Access-group name KRITIK2
!ToS BITLERINI İŞARETLEME
Policy-map ISARETLEME
Class KRITIK5
Set ip predence 5
Class KRITIK4
Set ip predence 4
Class KRITIK3
Set ip predence 3
…
!INTERFACE’LERE UYGULAMA
interface serial 1/0:1
Service-policy output ISARETLEME
NBAR
R1(config)#class-map match-any BLOCKED
R1(config-cmap)#match protocol http host "*youtube.com*"
R1(config-cmap)#exit
First I will create a class-map called “BLOCKED” and I will use match protocol to use NBAR. As you can see I match on the hostname “youtube.com”. The * means “any character”. Effectively this will block all sub-domains of youtube.com, for example “subdomain.youtube.com” will also be blocked. Now we need to create a policy-map:
R1(config)#policy-map DROP
R1(config-pmap)#class BLOCKED
R1(config-pmap-c)#drop
R1(config-pmap-c)#exit
The policy-map above matches our class-map BLOCKED and when this matches the traffic will be dropped. Last but not least we need to apply the policy-map to the interface:
R1(config)#interface fastEthernet 0/1
R1(config-if)#service-policy output DROP
Kısacası NBAR kullanması durumunda paketler tanımlanacağı için istenilen paket türleri çöpe atılabilir, istenilen paket türleri de işaretlenip öncelik verilmek süretiyle ağda daha hızlı hareket edebilir. Bu şekilde daha iyi ağ bir yönetimi sağlanır. Aşagıda örnek bir NBAR yapılandırması vardır.
- Paketleri çöpe atmak için;
Router(config)#class-map match-any nbarDeneme
Router(config-cmap)#match protocol bittorrent
Router(config)#policy-map copeAtma
Router(config-pmap)#class nbarDeneme
Router(config-pmap-c)#drop
- Paketleri işaretlemek için;
Router(config)#policy-map isaretleme
Router(config-pmap)#class nbarDeneme
Router(config-pmap-c)#set precedence 4 (Burada 0 ile 7 arasında sayı verilebilir. Boyama sayılarıdır sadece 5 voice için verilir.)
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
service-policy input copeAtma
- Paketlerin istatistiğini tutmak için yönlendiricinin ilgili interface(arayüzü)’ine girilerek,
Router(config-if)#ip nbar protocol-discovery
Router#sh ip nbar protocol-discovery
- Ayrıca PDLM yüklemek için;
Router(config)#ip nbar pdlm flash:/<pdlm’in ismi>
Komutları işletilir.--
access-list 10 permit any
class-map match-any example
match access-group 10
class example
police 8000 1000
interface GigabitEthernet2/0/25
service-policy input example1
policy-map example1
class example
police 8000 1000
---
ip access-list extended acl_voip
permit ip any any eq 5060 #5060 tan gelen her paketi acl_voip isimli bir access liste olusturuldu.
#eger bu kurali hedef ip den hedef ipye gondermek gerekiyor ise,
ip access-list extended acl_voip
permit ip host 1.1.1.1 host 2.2.2.2 eq 5060 # 1.1.1.1 IPsinden 2.2.2.2 ipsine giden portu 5060 olan servisler.
class-map match-all class_voip
match access-group name acl_voip #bu access liste ait bir classmap olusturuldu.
policy-map policy_voip #buradaki ornekte class_voip classina 8mbit bir limit verilmistir.
class class_voip
police 8000000 100000 exceed-action drop
interface GigabitEthernet0/2 #yukarda tanimlamalari yapilan degerler bir interface'e uygulanir.
service-policy input policy_voip
----
bandwith dagıtımı ıcın
policy-map sample
class camera
bandwidth percent 1
queue-length 1024
class class-default
bandwidth percent 99
fair-queue
class-map match-all VOICE
match vlan 100
!
policy-map VOICE-POLICY
class VOICE
priority percent 30
policy-map TRAFFIC-SHAPE
class class-default
shape average 10000000
service-policy VOICE-POLICY
interface GigabitEthernet0/1.100
description Voice Link
encapsulation dot1Q 100
ip address 10.1.11.x 255.255.255.0
service-policy output TRAFFIC-SHAPE
***
ASA
This example shows how to throttle the bandwidth to 1 Mbps for a specific user in the outbound direction:
You must apply this limitation on outside interface because this configuration only work on outside interface.
Bu konfigurasyonda dis interface'de limitleme yapılmalı , inside interface'deki limitleme calısmıyor.
11 kbyte 'a limitlemek için
access-list PORT extended permit tcp host 192.168.3.100 host 192.168.2.100 range 2000 6400
class-map LIMIT
match access-list PORT
policy-map POLICY
class LIMIT
police input 100000 20000 conform-action transmit exceed-action drop( buradaki input aynı interfaceden gelen , output baska interfaceden gelen)
2. bir kısıtlama icin;
access-list PORT2 extended permit udp any any eq 8739
class-map LIMIT2
match access-list PORT2
policy-map POLICY
class LIMIT2
police input 8000 1000 conform-action transmit exceed-action drop
service-policy POLICY interface inside
----
--
1. Öncelikle class-map’lerde kullanılacak erişim kontrol listeleri (ACL’ler) tanımlanmalıdır.
Sw_2950(config)# access-list 101 permit ip any 10.1.1.0 0.0.0.255
Sw_2950(config)# access-list 112 permit ip any 10.1.12.0 0.0.0.255
Sw_2950(config)# access-list 112 permit ip any 10.1.12.0 0.0.0.255
2. Sonraki adımda farklı gruplar için class-map tanımlanmalıdır.
Sw_2950(config)# class-map misafir_sınıfı
Sw_2950(config-cmap)# match access-group 101
Sw_2950(config-cmap)# exit
Sw_2950(config)# class-map idari_sınıfı
Sw_2950(config-cmap)# match access-group 112
Sw_2950(config-cmap)# exit
Sw_2950(config-cmap)# match access-group 101
Sw_2950(config-cmap)# exit
Sw_2950(config)# class-map idari_sınıfı
Sw_2950(config-cmap)# match access-group 112
Sw_2950(config-cmap)# exit
3. Bir sonraki adımda policy-map oluşturulur ve her class-map için uygulanacak bant genişliği değerleri belirtilir. “police” sonrasında belirtilen ilk değer bit cinsinden uygulanan bant genişliği sınırlamasını belirtir. Burst diye isimlendirilen ikinci değer ise bant genişliği sınırlandırması yapılmadan iletilebilecek trafiğin byte cinsinden miktarıdır.
Sw_2950(config)# policy-map Misafir_Idari
Sw_2950(config-pmap)# class misafir_sinifi
Sw_2950(config-pmap-c)# police 8000000 16384 exceed-action drop
Sw_2950(config-pmap-c)# exit
Sw_2950(config-pmap)# class idari_sinifi
Sw_2950(config-pmap-c)# police 32000000 32768 exceed-action drop
Sw_2950(config-pmap)# class misafir_sinifi
Sw_2950(config-pmap-c)# police 8000000 16384 exceed-action drop
Sw_2950(config-pmap-c)# exit
Sw_2950(config-pmap)# class idari_sinifi
Sw_2950(config-pmap-c)# police 32000000 32768 exceed-action drop
4. Policy-map’in anahtarın arayüzüne giriş yönünde uygulanması ile 10.1.1.0/24 ve 10.1.12.0/24 ağlarındaki kullanıcılara iletilecek toplam trafik 8Mb ve 32Mb ile sınırlandırılmış olacaktır.
Sw_2950 (config)# interface gigabitEthernet 0/1
Sw_2950 (config-if)# service-policy input Misafir_Idari
Sw_2950 (config-if)# service-policy input Misafir_Idari
Cisco 2960 Kenar Anahtarlarda Konfigürasyon
Catalyst 2960 anahtarlarda yukarıda belirtilen komutlar ile bant genişliği kontrolü yapılabilir. 2950 anahtarlardan farklı olarak sadece “mls qos” komutu ile anahtar üzerinde QoS aktif hale getirilmelidir. Tüm arayüzlere uygulanacak policy-map’lerde bant genişliği sınırlaması 1Mb ve katları şeklinde tanımlanmalıdır.
Ayrıca farklı olarak aggregate policer (ortak sınırlandırıcı) tanımlanıp bir policy-map’deki class-map (sınıf haritalar) tarafından bu sınırlandırıcıyı ortak olarak kullanmaları sağlanabilir. Aggregate policer aşağıdaki gibi yapılandırılabilir.
1. QoS switch’te aktive edilir.
Sw_2960(config)# mls qos
2. Aggregate policer tanımlanır.
Sw_2960(config)# mls qos aggregate-policer ortak_8Mb 8000000 16000 exceed-action drop
3. Policy-map’de kullanılan class-map’ler için aggregate policer kullanılır.
Sw_2960(config)# policy-map Misafir_Idari
Sw_2960(config-pmap)# class misafir_sinifi
Sw_2960(config-pmap-c)# police aggregate ortak_8Mb
Sw_2960(config-pmap-c)# exit
Sw_2960(config-pmap)# class idari_sinifi
Sw_2960(config-pmap-c)# police aggregate ortak_8Mb
Sw_2960(config-pmap-c)# exit
Sw_2960(config-pmap)# class misafir_sinifi
Sw_2960(config-pmap-c)# police aggregate ortak_8Mb
Sw_2960(config-pmap-c)# exit
Sw_2960(config-pmap)# class idari_sinifi
Sw_2960(config-pmap-c)# police aggregate ortak_8Mb
Sw_2960(config-pmap-c)# exit
4. Policy-map’in anahtarın arayüzüne giriş yönünde uygulanması ile 10.1.1.0/24 ve 10.1.12.0/24 ağlarındaki kullanıcılara iletilecek toplam trafik 8Mb ile sınırlandırılmış olacaktır.
Sw_2960 (config)# interface gigabitEthernet 0/1
Sw_2960 (config-if)# service-policy input Misafir_Idari
---
Router(config-cmap)# match protocol citrix
Router(config-cmap)# end
Router(config)# policy-map policy1
Router(config-pmap)# class class1
Device(config-pmap-c)# bandwidth percent 50
Device(config-pmap-c)# end
Device> enable
Device# configure terminal
Device(config)# interface gigabitethernet 0/4
Device(config-if)# service-policy input policy1
Device(config-if)# end
EXAMPLE:
hostname R2
!
ip cef
!
class-map match-all TELNET-TRAFFIC
match access-group name TELNET-TRAFFIC
class-map match-all HTTP-TRAFFIC
match access-group name HTTP-TRAFFIC
!
policy-map MARKING
class TELNET-TRAFFIC
set precedence 7
class HTTP-TRAFFIC
set dscp af12
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
service-policy input MARKING
!
interface FastEthernet0/1
ip address 192.168.23.2 255.255.255.0
!
ip access-list extended HTTP-TRAFFIC
permit tcp any any eq www
!
end
hostname R3
!
ip cef
!
class-map match-all AF12
match dscp af12
class-map match-all PREC7
match precedence 7
!
policy-map COUNTER
class AF12
class PREC7
!
interface FastEthernet0/0
ip address 192.168.23.3 255.255.255.0
service-policy input COUNTER
!
ip http server
R2#show policy-map interface FastEthernet 0/0
Example 2-
hostname R2 ! ip cef ! class-map match-all CALL_SIGNALING match dscp cs3 class-map match-all VOICE match dscp ef ! policy-map LLQ class VOICE priority 2000
( I will create a priority queue for 2000 Kbps)
class CALL_SIGNALING bandwidth 1000 ! interface GigabitEthernet0/1 ip address 192.168.12.2 255.255.255.0 ! interface GigabitEthernet0/2 ip address 192.168.23.2 255.255.255.0 service-policy output LLQ ! end
Example 2-
Hiç yorum yok:
Yorum Gönder